Could not find com.android.support:appcompat-v7:22.1.1

项目依赖appcompat-v7,cardview-v7。采用Android studio编译,发生如下错误。

从错误日志中可以看出,编译器会试着从三个位置查找该lib,首先是jcenter,然后是../ADT/sdk/extras/android/m2repository/..,然后是../ADT/sdk/extras/google/m2repository/..依次查找。最后发现安装通过SDK Manager升级Android Support Repository之后,/ADT/sdk/extras/google/m2repository/中就有该lib库了。

Could not find com.android.support:appcompat-v7:22.1.1

Could not find com.android.support:appcompat-v7:22.1.1



  copyright@黑月神话,转载请注明出处:vjson.com

发表评论